Google Calendar Outage

Incident Report for Stan

Resolved

This incident has been resolved.
Posted Sep 21, 2023 - 14:06 EDT

Investigating

Heads up! Google Calendar is currently experiencing a system outage that is affecting some calendar bookings on Stan. Our team is closely monitoring this issue and will update you as soon as Google Calendar has resolved the issue.
Posted Sep 21, 2023 - 10:55 EDT
This incident affected: Stan Stores.