Great news! Your emails are fixed!
Incident Report for Stan
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 20:47 EDT
Investigating
Great news, your emails are fixed! Thank you for your patience while we quickly worked to resolve everything. We want to reassure you that all emails will now deliver as expected, both transactional and flows.

If there’s anything you need, please reach out to friends@stanwith.me. We’re here for you!
Posted Aug 16, 2023 - 18:43 EDT
This incident affected: Admin Site.